System Requirements

Browser Requirements:

Your Covetrus Prescription Management Platform is built, tested, and optimized in the latest stable versions of:

  • Google Chrome
  • Mozilla Firefox
  • Safari
  • Microsoft Edge
  • Microsoft Internet Explorer (Version 11 only)

Please note that the application works best when your browser zoom level is set to 100%.

 

Mobile Requirements:

The platform is not currently optimized for mobile devices, but we do have a mobile application where you can create, approve, and renew. For more information, please see ScriptConnect Mobile App.

 

Additional Requirements:

Cookies must be enabled for the Covetrus Prescription Management Platform to work.